vpn’s-op-linux,-macos,-ios-en-android-kwetsbaar-voor-aanvallers
Advertentie

Een beveiligingslek in Linux, FreeBSD, OpenBSD, macOS, iOS en Android maakt het in bepaalde gevallen mogelijk voor aanvallers om verbindingen in de vpn-tunnel te kapen, te zien of er bepaalde websites worden bezocht en of de gebruiker een vpn gebruikt. De aanvaller hoeft hiervoor alleen pakketjes naar het doelwit te kunnen sturen. Dat stellen onderzoekers van de Universiteit van New Mexico.

Om de aanval uit te voeren moet een slachtoffer wel met een kwaadaardig wifi-netwerk zijn verbonden of moet de aanvaller op hetzelfde netwerk zitten. Vervolgens kan de aanvaller door het versturen van bepaalde pakketjes zien of de gebruiker een specifieke website bezoekt en is het mogelijk om verkeer in de tcp-stream te injecteren. Het probleem is aanwezig in vpn-implementaties zoals OpenVPN, WireGuard en IKEv2/IPSec, alsmede *nix-gebaseerde besturingssystemen. Het maakt daarbij niet uit of er van ipv4 of ipv6 gebruik wordt gemaakt.

Gebruikers kunnen verschillende maatregelen nemen om zich te beschermen, waaronder het inschakelen van reverse path filtering en bogon filtering, hoewel deze opties ook nieuwe problemen kunnen introduceren. Een andere mogelijke optie is het toevoegen van padding aan versleutelde pakketjes. De onderzoekers merken echter op dat dit geen bevredigende oplossingen zijn. Pas nadat er een goede workaround is gevonden zullen ze meer details over hun onderzoek vrijgeven.

Advertentie

LAAT EEN REACTIE ACHTER

Vul alstublieft uw commentaar in!
Vul hier uw naam in